The personal website of Chris Coyier

My New Microsoft Keyboard, ApplicationEnhancer, Leopard, and the Blue Screen of Death

So my RSI / Carpal Tunnel whatever in my hand has gotten quite bad. I’ve been wearing a brace and I bought a book to read up on it. It’s been getting worse and worse and it has really become obvious that I need to do something about it. Work a little less, have better posture, do more stretching/massage. But I thought what really might help as well is a better keyboard.

I went with the Microsoft Natural Ergonomic Keyboard 4000


I plugged her in and of course it worked right away. OS X is cool like that. But.. Of course it has a “Start” key where my option key should be and a “Alt” key where my Command key should be. So I figured it would pop in the CD and install the software, figuring it has some little lame control panel for adjusting that stuff. Restart required. Well, I’m in the middle of my day here, no big deal, I’ll do it later on tonight.

Later on that night I restart. Happy Apple chime, Happy Apple gray logo and spinny. Then… blue screen. Nothing. Sat there for 30 minutes (I gave it some time, just in case).

Well the CD was still in the drive, so I figured maybe it was trying to read that and having a problem. So I start up with the mouse button down to eject. Won’t eject (tried a few times).

OK, I’ll start up with the option key down and select the Hard Drive manually to make sure it’s starting up off that. Works fine, recognizes the Hard Drive (whew!). But still the blue screen of death.

I try a couple of random other tricks I could think of, but nothing was going here. I can’t even start up off a Leopard DVD to reinstall because the other disc is stuck in there. Boooo.

So I make an appointment for the Apple Store the next day. But, of course I just cant sit around waiting. So I ask my Twitter peeps and I get a great response. The problem is apparently a known issue with Leopard. It’s not Leopard’s fault but actually a little bugger called APE (Unsanity’s “ApplicationEnhancer”). John Gruber has a detailed article on the subject.

The difference in my case is that I wasn’t doing any kind of OS upgrade, and my installation was of a Microsoft application not Logitech. Apparently this problem spans many manufacturers. So apparently newer version of this are harmless, but Microsoft is still shipping old versions that absolutely rape Leopard machines. Nice. I say it’s not Leopard’s fault, because this software installs some files into places it really really shouldn’t be.

So I’m glad I got directed to that article, because it contained some detailed instructions on how to get yourself back from this. You need to boot into “Single User” mode (hold Command-S) in startup. It looks like white letters on a black screen, like Terminal. Then you have to enter some specific commands to remove the problematic files:

rm -rf /Library/PreferencePanes/Application\ Enhancer.prefpane
rm -rf /Library/Frameworks/ApplicationEnhancer.framework
rm -rf /System/Library/SystemConfiguration/ApplicationEnhancer.bundle
rm -rf /Library/Preferences/com.unsanity.ape.plist

Thank god! I actually had to do it twice, but my machine came back to life! Woohoo!

Now I’m one of those assholes who makes appointments to the Genius Bars and never shows up.

Oh, but the dumb little control panel for the keyboard DOES have a quick and easy way to fix the Command/Option problem: